aboutsummaryrefslogtreecommitdiffstats
path: root/libntru [disowned]/PKGBUILD
diff options
context:
space:
mode:
authorMattias Andrée <maandree@kth.se>2018-10-02 18:27:57 +0200
committerMattias Andrée <maandree@kth.se>2018-10-02 18:27:57 +0200
commit3be18bcabd64303d393ee95713a99866b415ff85 (patch)
tree4228699260ddd38a56c4f1f2ee1ffd12bdb11fdf /libntru [disowned]/PKGBUILD
parenttexlive-europecv texlive-europecv [disowned] (diff)
downloadaur-packages-3be18bcabd64303d393ee95713a99866b415ff85.tar.gz
aur-packages-3be18bcabd64303d393ee95713a99866b415ff85.tar.bz2
aur-packages-3be18bcabd64303d393ee95713a99866b415ff85.tar.xz
Disowned libntru
Signed-off-by: Mattias Andrée <maandree@kth.se>
Diffstat (limited to 'libntru [disowned]/PKGBUILD')
-rw-r--r--libntru [disowned]/PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/libntru [disowned]/PKGBUILD b/libntru [disowned]/PKGBUILD
new file mode 100644
index 0000000..13545bd
--- /dev/null
+++ b/libntru [disowned]/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Mattias Andrée <`base64 -d`(bWFhbmRyZWUK)@member.fsf.org>
+
+pkgname=libntru
+pkgver=0.4.1
+pkgrel=1
+pkgdesc='C Implementation of NTRUEncrypt'
+url='https://github.com/tbuktu/libntru'
+arch=('i686' 'x86_64')
+license=('custom:2-clause BSD')
+depends=('glibc')
+makedepends=('gcc' 'glibc' 'make' 'coreutils')
+source=("https://github.com/tbuktu/libntru/archive/${pkgver}.tar.gz")
+sha256sums=('a540763f12c496b057f75c7684274bafb4e62984e6b713720ceb7ea8f31229e5')
+
+build ()
+{
+ cd "${srcdir}/libntru-${pkgver}"
+
+ make -f Makefile.linux
+}
+
+package ()
+{
+ cd "${srcdir}/libntru-${pkgver}"
+
+ make -f Makefile.linux install DESTDIR="${pkgdir}"
+ rm -r "${pkgdir}/usr/share"
+}
+